You are here: Office-Outlook.com  / Outlook Forum

COM Add-ins, VS 2008 and .NET Framework 2.0

Home » Outlook addins and plugins development » Developer Outlook add-ins
COM Add-ins, VS 2008 and .NET Framework 2.0 [message #430263] Wed, 30 July 2008 09:21
XL-Dennis
Messages: 518
Registered: August 2006
Senior Member
Hi all,

When I create a new COM add-in based on the Shared Add-in template in VS
2008 Professional and select .NET Framework 2.0 I get problem to deploy the
solution on configuration where .NET Framework 2.0 only is installed.

The message that is showed during installation is that .NET Framework 3.5
must be installed before it can proceed.

I have tested on both Windows XP SP-3 and on Windows Vista SP-1 with the
same output.

On configurations with 2.0 and 3.5 or 3.0 and 3.5 versions of .NET Framework
the installation goes well.

As for the solution itself:
- All the references in the solutions is to version 2.0 of .NET Framework.
- The target Framework in the Advanced Compiler Settings is set to .NET
Framework 2.0.
- The prerequisites are either turned off or set to version 2.0 of .NET
Framework together with the Windows Installer 3.1

I could accept that when selecting the targeting version to 2.0 I would not
be able to create a COM add-in and instead be forced to use version 3.5.

But as it is now I would like to know how I can resolve it.

---------------
With kind regards,
Dennis
Weekly Blog .NET & Excel: http://xldennis.wordpress.com/
My English site: http://www.excelkb.com/default.aspx
Previous Topic:COM Add-ins, VS 2008 and .NET Framework 2.0
Next Topic:Outlook addin started directly by inspector window (c# .net 3.5)
Goto Forum: