You are here: Office-Outlook.com  / Outlook Forum
Home » Outlook addins and plugins development » Developer Outlook add-ins » Office Add-In Deployment is very dificult?
Office Add-In Deployment is very dificult? [message #682] Tue, 25 July 2006 04:24
michael
Messages: 22
Registered: July 2006
Location: NULL
Junior Member

Hello, i try sience two weeks to create a Add-In for Microsofts Word.
It works greate on my development machine with visual studio 2005
installed.

but if i try it on a naked windows xp machine, with .net 2.0 and office
2003 installed the add-in would not load. If i open the "COM Add-Ins"
window in word, i see that the registry entrys that my setup makes are
correct, cuz the add-in is still registred in this window, but if i hit
the checkbox and press the OK button, and now open the "COM Add-Ins"
window again, there is a message "Load Behavior: Not loaded. A runtime
error occurred during the loading of the COM Add-in". btw. Location is
"mscoree.dll" i' ve build my Add-In without "shim".. and the PIA's are
installed on this non developer machine..

I tryed many things to get fixed this..

My questions:
1. is there a way to get more information from word about the loading
problems? maybe a logfile
2. is it possible to deploy this addin on a non developer machine,
machine wide? so that other users also can use my Add-In?
3. did i need CAS without a "shim"?

thanks for your support, and sorry for my poor english...

Greets Mitch

Read Message
Previous Topic:office pia's
Next Topic:invalid Plugin
Goto Forum:
  

.:: Home ::.